Le script mt-check.cgi vous fourni des informations sur la configuration de votre système et détermine si vous avez tous les composants nécessaire pour exécuter Movable Type.

Informations système

Modules Nécessaire Vérification de l'état de

CGI::Cookie

Votre serveur possède CGI::Cookie (version 1.29).

File::Spec (version >= 0.8)

Votre serveur possède File::Spec (version 3.62).

Image::Size

Votre serveur possède Image::Size (version 3.2).

CGI

Votre serveur possède CGI (version 3.48).

Modules Stockage des données Vérification de l'état de

Les modules suivants sont requis par certaines options de stockage dans Movable Type. Afin d'exécuter le système, votre serveur a besoin d'avoir DBI et au moins l'un des autres modules d'installé.

DBI (version >= 1.21)

Votre serveur possède DBI (version 1.631).

DBD::mysql

Votre serveur possède DBD::mysql (version 4.041).

DBD::SQLite

Votre serveur possède DBD::SQLite (version 1.35).

DBD::Pg (version >= 1.32)

Votre serveur possède DBD::Pg (version 2.17.1).

DBD::SQLite2

Votre serveur possède DBD::SQLite2 (version 0.36).

Modules Optionnel Vérification de l'état de

Les modules suivants sont optionnels

Scalar::Util

Votre serveur possède Scalar::Util (version 1.42).

Crypt::DSA

Ce module accélère les enregistrements des auteurs de commentaires. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer Crypt::DSA.

Votre serveur n'a pas Crypt::DSA d'installé ou Crypt::DSA nécessite un autre module qui n'est pas installé.

XML::SAX

Votre serveur possède XML::SAX (version 0.96).

IPC::Run

Votre serveur possède IPC::Run (version 0.90).

Archive::Zip

Votre serveur possède Archive::Zip (version 1.56).

Storable

Votre serveur possède Storable (version 2.20).

SOAP::Lite (version >= 0.5)

Votre serveur possède SOAP::Lite (version 0.710.08).

List::Util

Votre serveur possède List::Util (version 1.42).

HTML::Entities

Votre serveur possède HTML::Entities (version 3.69).

Digest::MD5

Votre serveur possède Digest::MD5 (version 2.39).

Text::Balanced

Votre serveur possède Text::Balanced (version 2.0.0).

Crypt::SSLeay

Votre serveur possède Crypt::SSLeay (version 0.64).

GD

Votre serveur possède GD (version 2.46).

Archive::Tar

Votre serveur possède Archive::Tar (version 1.58).

Safe

Votre serveur possède Safe (version 2.27).

XML::Parser

Votre serveur possède XML::Parser (version 2.41).

IO::Uncompress::Gunzip

Votre serveur possède IO::Uncompress::Gunzip (version 2.069).

Digest::SHA1

Votre serveur possède Digest::SHA1 (version 2.13).

IO::Compress::Gzip

Votre serveur possède IO::Compress::Gzip (version 2.069).

XML::Atom

Votre serveur possède XML::Atom (version 0.35).

Image::Magick

Votre serveur possède Image::Magick (version 6.79).

LWP::UserAgent

Votre serveur possède LWP::UserAgent (version 6.05).

MIME::Base64

Votre serveur possède MIME::Base64 (version 3.08).

Mail::Sendmail

Ce module est nécessaire pour envoyer des emails via un serveur SMTP. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer Mail::Sendmail.

Votre serveur n'a pas Mail::Sendmail d'installé ou Mail::Sendmail nécessite un autre module qui n'est pas installé.

HTML::Parser

Votre serveur possède HTML::Parser (version 3.71).

File::Temp

Votre serveur possède File::Temp (version 0.22).

Vérification du système Movable Type terminé avec succès.

Vous êtes prêt à continuer ! Votre serveur dispose de tous les modules requis; vous n'avez pas besoin d'installer autre chose. Continuer avec les instruction d'installation.